Dealer Data

Incident Report for QV Systems

Resolved

This incident has been resolved.
Posted Apr 18, 2026 - 15:53 BST

Update

Dealer contacts and favourites have now been restored. We will continue to work on ensuring the integrity of the dealer database over the weekend.
Posted Apr 17, 2026 - 15:20 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 17, 2026 - 12:52 BST

Identified

We are aware of issues with dealer data following last night's release. Our team is working to resolve this as soon as possible.
Posted Apr 17, 2026 - 08:59 BST
This incident affected: Accelerate Application (Quotevine User Interface).