A fix has been implemented and we are monitoring the results
Posted Jun 24, 2025 - 16:34 BST
Investigating
We are currently aware of an issue causing some users to receive an error when attempting to load a relationship. We are currently investigating this is a top priority
Posted Jun 24, 2025 - 16:31 BST
This incident affected: Accelerate Application (Quotevine User Interface).