We are continuing to work on a fix for this issue.
Posted Aug 07, 2025 - 13:22 BST
Identified
The issue is being caused by a flood of API calls from one of email partners. We are working on implementing more robust defences against this behaviour.
Posted Aug 07, 2025 - 13:22 BST
Update
We are continuing to investigate this issue.
Posted Aug 07, 2025 - 11:59 BST
Investigating
We are aware of an issue with users unable to access our multi-tenant environment. We are investigating this issue.
Posted Aug 07, 2025 - 11:58 BST
This incident affected: Accelerate Application (Quotevine User Interface).